Update is needed Rated 2 out of 5 stars

Unfortunately it is just partially working with the latest revision of Firefox. Can you update please ?!