Seems to work with FF3 Rated 5 out of 5 stars

This great extension seems to work with FF 3.0.1.
As Brett Zamir said, you have to modify file "install.rdf" in extension archive .xpi (it's a zip file), and change value of "em:maxVersion" with "3.0.1" instead of "3.0a1".
Enjoy...