Rated 3 out of 5 stars

It appears this plug-in is not supporting MacOS X 10.5 PPC. As there are still many users enjoying PPC architecture, it would be great having supported this platform as well ... Major bank and eshop support will be great for deployment of this great plugin.

This review is for a previous version of the add-on (1.1.3). 

Please try version 1.0.4 <https://addons.mozilla.org/en-US/firefox/addon/dnssec-validator/versions/1.0.4>, it should work for you ;)