Rated 5 out of 5 stars

Doesn't work for me, FF v 3.5.5, Ubuntu9.10

This review is for a previous version of the add-on (2.0.4). 

New version

Please, try the new version (2.0.5). Some fixes had been made and now it's works properly on Linux.