Rated 5 out of 5 stars

I refuse to upgrade my main computer to Firefox 4 until Distrust is compatible with it. Sticking with 3 until then.

Works for me on Firefox 3.6.* Rated 5 out of 5 stars

You can get the working 0.8.1 version for Firefox 3.6.* here:
http://tadd.free.fr/temp/stayOnline/firefox-addons/distrust-0.8.1-fx.xpi

This was done thanks to "Untitled n° 4" 's suggestion!

Rated 5 out of 5 stars

Works for me on Firefox 3.6.*. Here's what needs to be done:
1. Download distrust xpi file.
2. Uncompress the xpi file (essnetially a zip file).
3. Edit install.rdf file with a text editor and change line 19 (one before last) from 3.0.* to 3.6.* and save your changes.
4. Compress again to a xpi file (again, a zip file, so you can zip the file and change extension to xpi)
5. Install.

Rated 3 out of 5 stars

Still no news about a 3.6.* compatible version. The author web page domain isn't even loading. Note to Shyam: Stealther (1.0.9) seems to work with FF 3.6.3 and is an acceptable alternative to Distrust.

Rated 3 out of 5 stars

It looks like this addon does not work with FF3.6 even after bumping up the version! Did any of you try this with 3.6?
Somehow, neither Distrust nor Stealther seems to work with 3.6!!
I think the "Close n forget" addon comes closer... but still needs more features

Rated 5 out of 5 stars

http://cloud.github.com/downloads/arminhs/distrust/distrust-0.8.2.xpi

Rated 5 out of 5 stars

For version 3.5.* , download this unofficial version until Itamar releases a new update :)

-->

http://www.luminusltd.net/admin/distrust-0.8.2-fx.xpi

additional download info Rated 5 out of 5 stars

I googled it and found:
http://www.brothersoft.com/distrust-64852.html

You can right-click and save rather than download/install. This should allow you to edit the archive.

Modify Settings for FF 3.5.1 Rated 5 out of 5 stars

Hello Steveg

I'm interested in downloading Distrust and modifying the settings for:
Change
em:maxVersion="3.0.*" />
to
em:maxVersion="3.6.*" />

FF keeps launching the install add on window and failing, and I'm not sure how to download the file to modify the settings as you suggested.

Any help would be greatly appreciated because this is one of my favorite add-ons.

Thanks

Great! - works with 3.5 Rated 5 out of 5 stars

This does work with firefox 3.5
I uninstalled it then downloaded it from:
http://www.gness.com/distrust/download/distrust-0.8.1.xpi

Then use winzip, winrar, etc. to view the contents. Extract index.rdf and open it with Wordpad.

Change
em:maxVersion="3.0.*" />
to
em:maxVersion="3.6.*" />

Rated 5 out of 5 stars

I comletely agree with Magante93, Distrust is a much better option than the built-in solution of Firefox 3.5.
Thanks to "Nightly Tester Tools"extension I forced the compatibility and it seems to work as good at it was with previous versions of Firefox.

Plugin better than Firefox's private browsing Rated 4 out of 5 stars

Update:
Following the advice from aifol; I installed "Nightly Tester Tools" and forced the compatibility on distrust.
I was able to installed and and although it seems to be installed and function correctly it is not working as it should.
I see errors under the Error Console \ Messages:
"Failed to load XPCOM component: C:\Documents and Settings\fmendez\Application Data\Mozilla\Firefox\Profiles\kp5eufkc.default\extensions\trustme@gness.com\components\dtIDistrustService.xpt.old"
"
"Failed to load XPCOM component: C:\Documents and Settings\fmendez\Application Data\Mozilla\Firefox\Profiles\kp5eufkc.default\extensions\{635abd67-4fe9-1b23-4f01-e679fa7484c1}\components\extconfig.js"
On a simple test:
I logged out of a site, then turned on distrust; I logged back into the site and turned off distrust hoping all of my session keys and other files have been deleted.

When I went back to the site, I was still logged onto the site, which means distrust didn't clean my traces for that site.


Great plugin.
I would like to see this plugin available for version 3.5*.
This plugin is far better to use than the built-in "private browsing"
Because you can activate it on and off while browsing without having to restart your browser.

Rated 4 out of 5 stars

On ff35 b4, hacked the xpi to update maxVersion in index.rdf (http://tr.im/nkAk).
After adding, restrating and browsing around a few sites, I restrated the browser and history and cookies were gone.
*works for me*

DOES NOT WORK WITH FIREFOX 3.0.10 Rated 3 out of 5 stars

It's been a great add-on before, but now it does not work with the latest FireFox at all. Do not install it, try again later when they've updated it.

Rated 4 out of 5 stars

This addon is far superior to I.E. 8's "IN PRIVATE BROWSING". With I.E. 8 the user is unable to utilize their Key Scrambler,while Key Scrambler is completly compatible with the Distrust feature. Also, Distrust is easy to use, but is not 100%. Hopefully it can be slightly improved.

Rated 1 out of 5 stars

doesn't work as told. leaves about:config stuff. hangs up machine. (tested this)

Rated 3 out of 5 stars

Private Browsing works better.

Doen't work in FF 3.0.6 Rated 1 out of 5 stars

used it for years LOVED it, until FF 3.0.6. DOESN'T work in this environment. Doesn't clear anything, not the URL, not the history library, NADA!

Rated 5 out of 5 stars

Great program, but I agree with jigajigajoo. A way to customize the keyboard shortcut would help a lot.

Rated 5 out of 5 stars

Great application, works as advertised. Simple, and never had any problems. I would suggest, however, that you either add a way to change the keyboard shortcut, or at least change it from Crtl+Shift+H, which is the shortcut for the history in Firefox 3. Maybe Crtl+Alt+H, as it isn't occupied by anything of which I know. (yay for proper grammer)