Works for me on Firefox 3.6.* Rated 5 out of 5 stars

You can get the working 0.8.1 version for Firefox 3.6.* here:
http://tadd.free.fr/temp/stayOnline/firefox-addons/distrust-0.8.1-fx.xpi

This was done thanks to "Untitled n° 4" 's suggestion!