Rated 5 out of 5 stars

Works for me on Firefox 3.6.*. Here's what needs to be done:
1. Download distrust xpi file.
2. Uncompress the xpi file (essnetially a zip file).
3. Edit install.rdf file with a text editor and change line 19 (one before last) from 3.0.* to 3.6.* and save your changes.
4. Compress again to a xpi file (again, a zip file, so you can zip the file and change extension to xpi)
5. Install.