Great! - works with 3.5 Rated 5 out of 5 stars

This does work with firefox 3.5
I uninstalled it then downloaded it from:
http://www.gness.com/distrust/download/distrust-0.8.1.xpi

Then use winzip, winrar, etc. to view the contents. Extract index.rdf and open it with Wordpad.

Change
em:maxVersion="3.0.*" />
to
em:maxVersion="3.6.*" />