Rated 5 out of 5 stars

Great add-on.

Unfortunately the update 0.5-->0.6 doesn't work at this moment (download error 228).

Fortunately 0.5 still works with FF3.6 so I just have to be patient ;-)

This review is for a previous version of the add-on (0.6).