Rated 5 out of 5 stars

DictionarySearch will work with Firefox 4 if you unzip the .XPI file and change the "maxVersion" field in the INSTALL.RDF file to something like 4.5.

Or you can download a copy that I updated myself. This .XPI file can be installed directly into FF4:

http://dl.dropbox.com/u/13679268/dictionarysearch_4.0.1_FF4.xpi

This review is for a previous version of the add-on (4.0.1.1-signed).