Dict Version History

21 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 0.8.1 42.8 kB Works with Firefox 16.0 and later, SeaMonkey 2.16 and later, Thunderbird 16.0 and later

Added support for selecting preferred database and strategy in the preferences.

Version 0.7.4 36.1 kB Works with Firefox 16.0 and later, SeaMonkey 2.16 and later, Thunderbird 16.0 and later

Version 0.7.3 36.1 kB Works with Firefox 16.0 and later, SeaMonkey 2.16 and later, Thunderbird 16.0 and later

Made compatible with SeaMonkey

Version 0.7.2 43.8 kB Works with Firefox 16.0 and later, Thunderbird 16.0 and later

Added dict.bibleonline.ru to the default list of servers in the preferences.

Version 0.7.1 43.7 kB Works with Firefox 16.0 and later, Thunderbird 16.0 and later

  • Miscellaneous security hardening
  • Reduced the namespace pollution to make Dict more compatible with other add-ons.
  • The CSS for the closest match page no longer logs a warning.
  • Dict now shows a clear error when it cannot to a remote host.
  • Dict now gives user feedback for malformed dict URIs.
  • Get the extension to work on Thunderbird, again.

Version 0.6.83 52.9 kB Works with Firefox 1.0 and later, Thunderbird 1.0 - 3.1.*

This version fixes a major issue that made the addon incompatible with non-English DICT servers.

Version 0.6.81 55.3 kB Works with Firefox 1.0 and later, Thunderbird 1.0 - 3.1.*

Updated default set of DICT servers

Version 0.6.78 56.3 kB Works with Firefox 1.0 and later, Thunderbird 1.0 - 3.1.*

Made compatible with Thunderbird 3.1

Version 0.6.76 56.3 kB Works with Firefox 1.0 - 3.6.*, Thunderbird 1.0 - 2.0.0.*

* Marked as compatible with Firefox 3.5.*
* Fix a bug that prevented the dict:// protocol handler from working on Firefox 3.5.

Version 0.6.75 56.3 kB Works with Firefox 1.0 - 3.5.*, Thunderbird 1.0 - 2.0.0.*

Marked as compatible with Firefox 3.0.1.
Fixed a window sizing problem on Firefox 3.0.1.
Mitigated an incompatibility with the Menu Editor addon.

Version 0.6.74 56.3 kB Works with Firefox 1.0 - 3.0.*, Thunderbird 1.0 - 2.0.0.*

Updated to be compatible with Firefox 3.0.

Version 0.6.73 60.4 kB Works with Firefox 1.0 - 3.0pre, Thunderbird 1.0 - 2.0.0.*

Updated to work with pre-release versions of Firefox 3.0.

Changed the word "Define" to "Look Up" in the context menu.

Version 0.6.72 56.3 kB Works with Firefox 1.0 - 3.0b2, Thunderbird 1.0 - 2.0.0.*

Updated to be compatible with Firefox 3.0b2

Version 0.6.71 56.3 kB Works with Firefox 1.0 - 2.0.0.*, Thunderbird 1.0 - 1.5.0.*

Version 0.6.70 55.3 kB Works with Firefox 0.7 - 1.5.0.*, Thunderbird 1.0 - 1.5.0.*

This release is compatible with Thunderbird 1.5 and Firefox 1.5.0.1.

Dict does not work through a proxy server.

Dict does not work on MacOS (something to do with having a single button mouse).

Version 0.6.14 55.3 kB Works with Firefox 0.7 - 1.5.0.*, Thunderbird 1.0 - 1.5b1

This release is compatible with Firefox 1.5 and Thunderbird 1.5 Beta.

Version 0.6.6 60.4 kB Works with Firefox 0.7 - 1.0, Thunderbird 1.0 - 1.0

This release fixes the incompatibilty with FF 1.0.3.

Version 0.6.5 60.4 kB Works with Firefox 0.7 - 1.0, Thunderbird 1.0 - 1.0

Version 0.6.1 49.2 kB Works with Firefox 0.7 - 1.0, Thunderbird 1.0 - 1.0

Version 0.5.16 45.1 kB Works with Firefox 0.7 - 1.0

Version 0.5.10 44.0 kB Works with Firefox 0.7 - 0.10