install in new firefox version Rated 4 out of 5 stars

This is giving me trouble installing on the new version of Firefox 2.0.0.12

Anyone else having trouble?

Thanks!