Love it! Rated 5 out of 5 stars

Wonderful extension, been using for long time under v2, not a fan of the new Delicious Bookmarks. Got it to work with FF3b5... If you upgrade to v3 and have it previously installed you must uninstall it first (updating currently installed version did not work for me).

Download a fresh copy of the XPI, hack install.rdf to update em:maxVersion, pack/ZIP it back up, then install locally. Worked OK for me and now I have the wonderful extension on FF3!! :)