Rated 5 out of 5 stars

I think this should be default built-in Firefox 3.6+.
A Must have Add-on.
Excellent

This review is for a previous version of the add-on (4.3).