Rated 5 out of 5 stars

The most useful extension for me.
Does not work in FF4 + Ubuntu 10.10
but FF3.6 + Ubuntu works fine