not suit for current final release of FF (3.0)?! Rated 2 out of 5 stars

I like to see it available for current full version of Firefox!

This review is for a previous version of the add-on (0.0.5). 

True, only Fx 3.1 and higher

Because of new features introduced in Fx 3.1, CSS Usage only works with 3.1 and higher. I hope Forefox 3.1 will be released shortly so this is no longer an issue.