Still waiting for FF6 compatibility Rated 4 out of 5 stars

This is the only extension that forces me to use FF3 and FF6 appeared, so please write something back, should i hope and wait for an update or should i start using FF6 :( without this nice extension.

This review is for a previous version of the add-on (0.5.253). 

It works now!

Support for Firefox4-Firefox6 has been submitted and is waiting approval. To access this version now, click on 'Version Information' at the bottom of the CookieSwap Add-On page and then click on 'View All Versions'. In there, you can find version 0.5.273.

Waiting for FF4 compatibility Rated 5 out of 5 stars

The only thing that forces me to use FF3.6 is this plug-in....so keep up the good work, and hurry up :D

This review is for a previous version of the add-on (0.5.253).