Firefox 3.6.8 Install Compatibibility Issue Rated 2 out of 5 stars

Addons dialog in FF3.6.8 says it is not compatible. Max Install Ver. string for 1.0.3 in install.rdf still says:maxVersion 3.5.* I already have compatibility checking disabled.
Edit the install.rdf?
Why are there so many (often great) Addons with virtually no explanation of what they do or how they work? It seems to have become an institution here to put something up without any info at all and to keep it that way for years.

This review is for a previous version of the add-on (2.2).