Rated 3 out of 5 stars

Firefox 3.6.8 Install Compatibibility Issue
Addons dialog in FF3.6.8 says it is not compatible.
I already have compatibility checking disabled.
Max Install Ver. string for 1.0.3 in install.rdf still says: maxVersion 3.5.* while at the top of this page it says Firefox 2.0 - 3.6.*
Edit the install.rdf?
I just want to Enable all cookies, Protect 2 cookies and Del ete all others with a button in 1 click. (a blocklist, and a whitelist is ok), Nothing so far will do it.
Update: I edited the install.rdf and installed it and it seems ok so far but it can't do the above.

This review is for a previous version of the add-on (1.0.3.1-signed).