Rated 5 out of 5 stars

Excellent! Also, compatible with the FF version 15. Thank you!

This review is for a previous version of the add-on (1.1.0.1-signed).