not 3.6 compatible? Rated 2 out of 5 stars

refused to install on FF 3.6