A Bit Confused Rated 5 out of 5 stars

I don't understand this, I just updated to Thunderbird 3.0 - this says it will work with "Thunderbird: 1.5b – 3.0a1" but it's not working.