all is well Rated 5 out of 5 stars

delighted sockpuppets notwithstanding, thanks to the developer for addressing the problems. the update my deleted review reply email mentioned fixed them

This review is for a previous version of the add-on (17.8). 

missing review from before the update Rated 3 out of 5 stars

Developer, Mozilla please INFORM ME IF REVIEW DOES IN SOME WAY NOT CONFORM TO GUIDELINES. It is disconcerting to receive email notifying me of a reply to my review, and then to visit the site and find the review is inexplicably gone.

The following review, posted 27 Mar, disappeared for reasons unknown.
[As the problem is now supposedly fixed, I will rate as neutrally as possible]

===============


WTF indeed. Also do not want to have to register for support. Something has gone very amiss with the Mar 26 update. The labels in the tabs are no longer legible.

It seems the home page comes up OK. New tabs come up OK. All other tabs are illegible as per https://imgur.com/rJsnPjU


Also, the link to the given for previous versions appears to be broken. That was https://addons.mozilla.org/en-US/firefox/1368/history/


Where to find old versions of this extension is here; https://addons.mozilla.org/en-US/firefox/addon/colorfultabs/versions/

Please note that the most desirable version to roll back to his missing. The last one we had, 17.7, is not there. The next most recent available is 17.6, which has attracted complaints about adware.

W T F . A maze/quagmire of grrRRR

==================
ADDENDUM I rolled back this extension to version 17.6, and experienced a return of issues that I had thought were caused by TabKit. In fact the update of colorful tabs to 17.7 must have resolved those issues. The problems were:
1. moving a tab caused all tabs between the place of origin and the destination to move far across to the right in a slab so that the sidebar had to be widened radically for them to be accessible again
2. the cross on each tab that should close it didn't work. tabs could not be closed

This review is for a previous version of the add-on (17.8).