Extend support for Clipmarks; not Amplify Rated 1 out of 5 stars

I've tried Amplify, and that service is definitely second best by far compared to the original Clipmarks network. Please extend compatibility for the Clipmarks Addon through Firefox 5 and beyond!

This user has a previous review of this add-on.