Rated 1 out of 5 stars

It isn't compatible with Firefox 4