Rated 5 out of 5 stars

It seems to exist a 0.8 version compatible with Firefox 3.5, yust click on "See All Versions" (on the addon page) and install the first addon of the list (0.8)
;-)

This review is for a previous version of the add-on (0.8).