CLiCk, Speak.js Version History

2 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 1.6.24 677.4 kB Works with Firefox 14.0 and later

Changes since the last version:
  • Created a fix for a Speak.js error that occurs when the selection being read starts with a minus.
  • Minor changes to the window.setTimeout calls to avoid validation warnings.
  • Some trivial code changes suggested by JavaScript Lint (http://www.javascriptlint.com/index.htm).

Known Issues:
  • This version of CLiCk, Speak.js no longer features separate add-ons for CLC-Utilities and CLC-4-TTS. It is most likely incompatible with other extensions based on CLC-4-TTS.
  • The voice will be rather robotic in nature and it probably only works for English (which I hope to fix in a future version).

Version 1.6.17 677.3 kB Works with Firefox 14.0 and later

New features:
  • The extension is no longer a bundle with three add-ons. It now consists of a single extension that only shows up once in your Add-ons Manager.
  • New About dialog.
  • Minor fixes to the Options dialog.
  • Gave the extension an icon.
  • Replaced DOM Mutation Events with a Mutation Observer.
  • Added "extensions." to the preference names.
  • Fix some undeclared and global variable issues.

Known Issues:
  • This version of CLiCk, Speak.js no longer features separate add-ons for CLC-Utilities and CLC-4-TTS. It is most likely incompatible with other extensions based on CLC-4-TTS.
  • The voice will be rather robotic in nature and it probably only works for English (which I hope to fix in a future version).