Does not work on 64-bit Linux Rated 1 out of 5 stars

The addon is just a thin (technically unnecessary) launcher to start a Java app. Which in turn uses binary JNI extensions which are only provided as 32-bit binaries, so it fails on 64-bit systems, which is most systems these days.

Can you please switch to industry standards? It's not the 20th century anymore.