Doesn't work! Firefox 51 or earlier, even on the version just released! Rated 1 out of 5 stars

Seriously, how lazy was this? Brand new version of the plugin due to a security error, and it doesn't support Firefox 52!