Doesn't work for me on my mac Rated 1 out of 5 stars

I've got the latest version of firefox for Mac (at IBM) and it says version 52, so the version must be for a different OS. I had to use Safari, and it worked fine using that browser, no add-on necessary.

This review is for a previous version of the add-on (1.0.9).