Rated 3 out of 5 stars

author, please update this addon to work with firefox 3.6. its very simple, just open up the .xpi as if it was a zip file, and change the first file and replace 3.5 with 3.6. it has been proven to work on 3.6, so please update it!