Rated 5 out of 5 stars

Needs update for ff 3.5 so that incompatibility messages stop appearing,
BUT works perfectly for me using
Nightly Tester Tools
https://addons.mozilla.org/en-US/firefox/addon/6543