Update needed Rated 4 out of 5 stars

Please update for Firefox 3.1b3