I really need this addon Rated 5 out of 5 stars

Hope this addon can support firefox 3 as early as possible! because I can't use firefox 3 without this addon!

This review is for a previous version of the add-on (0.2.1.1).