Rated 5 out of 5 stars

Works fine in 3.5 if Nightly Tester Tools is used to override compatibility.