Rated 3 out of 5 stars

On Version 7 you need only set extensions.checkCompatibility.nightly and it will always work for future versions like Version 8 and so on

This review is for a previous version of the add-on (1.1). 

This is true, but it doesn't help Aurora, Beta, and release users who want to use add-ons not yet marked compatible.