Rated 5 out of 5 stars

So far this is the extension I miss the most since upgrading to FF 3.6. I'm begging you (take my word for it, I'm on my knees with my hands clasped) to upgrade, I miss it a lot. I tried forcing compatibility but this did not work.