Easily fixed to work with Firefox 3.6 Rated 5 out of 5 stars

This is easily fixed to work with Firefox 3.6 . . . in the extension there are 4 files (about.xul, AdvancedDialog.xul, c4c.xul, & options.xul) simply remove the copyright symbol from line 5. That's it and it works again.

I have sent feedback to the developer with this info, so maybe it will be updated shortly since it is such a simple fix.

This review is for a previous version of the add-on (1.6).