Rated 3 out of 5 stars

Doesn't work w/ Firefox 3.5. I've told them about this, but they don't seem to care to update it. Probably missed a few sales to me that they otherwise would have gotten.