Great Extension, but too many false positives for Google Docs Rated 5 out of 5 stars

This is an awesome extension, just what I was looking for. It would be nice if you could add an option to disable the warnings for new certs and only warn on changed certs, even if the preference didn't have a GUI. The new cert dialog pops up so much I dug into CertPatrol.js and commented out the openDialog for outnew... but I'll need to repeat for each update until you add it as a feature.

Update 2011-01-20: Thanks! The new version is great, except I am constantly getting false positives for Google Docs. Unfortunately, this is also a very important site that I want Cert Patrol's protection. They're obviously using multiple certificates on different servers, and as I'm swapped between servers I keep seeing updates.

So... how hard would it be to add the ability to keep multiple versions of the same certificate? Or, alternatively, to say that I trust a specific CA for google (in this case, Google has its own intermediate CA) but want to be notified if I see any others.

To give you an idea of the false positive problem, I get this several times a day, to the point that I find myself trained to ignore the warnings.

This review is for a previous version of the add-on (1.2.3). 

That bad?

Do you encounter so many new certificates all the time? I'll find a solution. It should be better than just to ignore first encountered certificates since MITM may already be happening then, but also better than to disturb the user with pop-ups if they are definitely too many.

Update: I uploaded 1.3.5beta which has options to make less intrusional notification boxes instead of pop-ups for all lesser threatening events. :)