Rated 5 out of 5 stars

I'm using it just fine in FF4... I don't check compatibility and disabled what I had to after the update. Has worked just fine; zero issues.

This review is for a previous version of the add-on (0.7.9). 

FF4 version upcoming

I just uploaded a version for FF 4 and it's going through the review process. If you want to get it beforehand, you can get it here:

http://cachestatus.googlecode.com/files/cachestatus_0.7.10.xpi