Excellent addon and compatible with Firefox 3.5 ! Rated 5 out of 5 stars

Excellent addon ! Thanks for all.
And to answer GermanFreme82 and maybe others following this version on Mozilla's website isn't the lastest. So you have to go to the source http://code.google.com/p/cachestatus/downloads/list (thanks Eraesr) and choose the lastest 0.7.9 which DO work with firefox 3.5

Hope it helps :) Bye.

This review is for a previous version of the add-on (0.7.9).