Incompatible with version 28.0 Rated 5 out of 5 stars

Actually quite useful but there is a problem with the latest 28.0. Browser can't run with normal functionality. Mac users can press Option and open in safe mode and then remove this plugin for now. I'll check to see if the owner could update to new version from time to time. Desperately need it :)

Version update for FF 4 Rated 4 out of 5 stars

Dude, please do this version update. It is really handy tool and we need it. Let me know if you need a help.

This review is for a previous version of the add-on (0.81).