Needs Updated to at least Firefox 3.1b4pre Rated 3 out of 5 stars

Firefox 3.1 Beta 3 has already been released so this wouldn't even work with the current Official Beta release of Firefox 3.1

This review is for a previous version of the add-on (1.4).