Browser Border Version History

3 versions

Be careful with old versions!

These versions are displayed for reference and testing purposes. You should always use the latest version of an add-on.

Version 1.6.5 6.0 KiB Works with Firefox 3.0 - 3.7a4pre

3.6.* support

Version 1.6.3 6.0 KiB Works with Firefox 3.0 - 3.5.*

Update for Fx3.5

Version 1.6.2 6.0 KiB Works with Firefox 3.0 - 3.5b4