Rated 1 out of 5 stars

This extension doesn't seem to be supported any more, yet it's over-wrights standard error pages which are needed when you come across a site with an invalid security certificate which you still need to access. If you install this you will eventually remove it again soon after.