Another Cunning ploy to Remove British English? lol Rated 1 out of 5 stars

With regard to Psilax's comment, no the version available for Download at my post date isn't for Firefox 3.0.11, the max version is for Firefox 2.0b2, so this is for Firefox version 1 & Firefox 2 betas only! Someone must be putting up old versions because no one bothered to change the version number. I am sure there was a version for download which worked for Firefox 2 & 3 before.

I have had to change the maxversions to 3.6 for all products so it will install until someone at Mozilla fixes the download.

This review is for a previous version of the add-on (1.19).