Not compatible with 5.0.1 Rated 4 out of 5 stars

This is one of my most used extensions, but it is not compatible with the latest release of Firefox, 5.0.1. Please uipdate. Thanks.

This review is for a previous version of the add-on (1.33). 

Updated compatibility with Firefox 5.*