Rated 4 out of 5 stars

Doesn't seem to work with FF 3.6b yet