Not working for 3.0.3 Rated 5 out of 5 stars

I changed the max version to 3.0.3 in the install.rdf. But it didnt work for me. Did anyone try for 3.0.3?